Программное решение задач ЕГЭ по информатике

Задача 6825. Источник: Поляков. Задание КИМ 12

Страница задачи 6825

(А. Богданов) Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.

  1. заменить (v, w)
  2. нашлось (v)

Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Если цепочки v в строке нет, эта команда не изменяет строку. Вторая команда проверяет, встречается ли цепочка v в строке исполнителя Редактор.

Дана программа для исполнителя Редактор:

НАЧАЛО
ПОКА нашлось (71) ИЛИ нашлось (72) ИЛИ нашлось (73)
  ЕСЛИ нашлось (71)
    ТО заменить (71, 227)
  КОНЕЦ ЕСЛИ
  ЕСЛИ нашлось (72)
    ТО заменить (72, 37)
  КОНЕЦ ЕСЛИ
  ЕСЛИ нашлось (73)
    ТО заменить (73,17)
  КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ

На вход приведённой выше программе поступает строка, начинающаяся с символа «7», а затем содержащая n+1 цифру «1», n+2 цифр «2» и n+3 цифр «3», расположенных в произвольном порядке. Определите значение n, при котором сумма числовых значений цифр строки, получившейся в результате выполнения программы равна 9n.

Решение

В данной задаче порядок цифр не важен, т.к. каждая цифра после цифры 7 заменяется на какую-то комбинацию цифр перед данным символом. По этой же причине не требуется реализовывать сам алгоритм обработки строки, а достаточно посчитать конечную сумму.

Данную задачу так же можно решить без программирования, составив и решив уравнение
7 + (n + 1) * 4 + (n + 2) * 3 + n + 3 = 9 * n.

Python

for n in range(1, 1000):
    r = 7 + (n + 1) * 4 + (n + 2) * 3 + n + 3
    if r == 9 * n:
        print(n)
        break

PascalABC

var
    n, r: Integer;
begin
    for n := 1 to 1000 do
    begin
        r := 7 + (n + 1) * 4 + (n + 2) * 3 + n + 3;
        if r = 9 * n then
        begin
            Writeln(n);
            break;
        end;
    end;
end.

C++

#include <iostream>
using namespace std;
int main()
{
    for (int n = 1; n < 1000; n++)
    {
        int r = 7 + (n + 1) * 4 + (n + 2) * 3 + n + 3;
        if (r == 9 * n)
        {
            cout << n << endl;
            break;
        }
    }
}

Ответ

20

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: