Программное решение задач ЕГЭ по информатике

Задача 6783. Источник: Поляков. Задание КИМ 24

Страница задачи 6783

(А. Рогов) Текстовый файл 24-263.txt состоит не более чем из 106 символов и содержит только заглавные буквы латинского алфавита. Определите максимальное количество идущих подряд символов, среди которых любые два подряд идущих символа различны.

Решение

Просматриваем строку со второго символа. Если текущий символ не равен предыдущему, цепочка продолжается, иначе текущий символ становится первым символом новой цепочки.

Python

s = open('24-263.txt').readline()
k = 1
mx = 1
for i in range(1, len(s)):
    if s[i] != s[i - 1]:
        k += 1
        mx = max(mx, k)
    else:
        k = 1
print(mx)

PascalABC

var
    k, max, i: Integer;
    s: String;
    f: TEXT;
begin
    Assign(f, '24-263.txt');
    Reset(f);
    Readln(f, s);
    k := 1;
    max := 1;
    for i := 2 to s.Length do
        if s[i] <> s[i - 1] then
        begin
            k := k + 1;
            if k > max then
                max := k;
        end
        else
            k := 1;
    Writeln(max);
end.

C++

#include <iostream>
#include <fstream>
using namespace std;
int main()
{
    ifstream f;
    f.open("24-263.txt");
    string s;
    f >> s;
    int k = 1, max = 1;
    for (int i = 1; i < s.length(); i++)
        if (s[i] != s[i - 1])
        {
            k++;
            if (k > max)
                max = k;
        }
        else
            k = 1;
    cout << max << endl;
}

Ответ

302

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: