Задача 6737. Источник: Поляков. Задание КИМ 12
(А. Рогов) Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки символов.
- заменить (v, w)
- нашлось (v)
Первая команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Если цепочки v в строке нет, эта команда не изменяет строку. Вторая команда проверяет, встречается ли цепочка v в строке исполнителя Редактор.
Дана программа для исполнителя Редактор:
НАЧАЛО
ПОКА нашлось(17) ИЛИ нашлось(377) ИЛИ нашлось(777)
  ЕСЛИ нашлось(17)
    ТО заменить(17, 1)
  КОНЕЦ ЕСЛИ
  ЕСЛИ нашлось(377)
    ТО заменить(377, 73)
  КОНЕЦ ЕСЛИ
  ЕСЛИ нашлось(777)
    ТО заменить(777, 3)
  КОНЕЦ ЕСЛИ
КОНЕЦ ПОКА
КОНЕЦ
На вход приведённой выше программе поступает строка, начинающаяся с цифры «1», а затем содержащая n цифр «7» (n – натуральное число). Определите наименьшее значение n, при котором в строке, получившейся в результате выполнения программы, количество цифр «3» равно 2.
Решение
Перебирая в цикле значения n, обработаем каждую строку приведенным алгоритмом до получения требуемого результата.
Python
for n in range(1, 1000):
    s = '1' + '7' * n
    while '17' in s or '377' in s or '777' in s:
        if '17' in s:
            s = s.replace('17', '1', 1)
        if '377' in s:
            s = s.replace('377', '73', 1)
        if '777' in s:
            s = s.replace('777', '3', 1)
    if s.count("3") == 2:
        print(n)
        break
PascalABC
function replace(s, s1, s2: String): String;
var
    p: Integer;
begin
    result := s;
    if s.Contains(s1) then
    begin
        p := s.IndexOf(s1) + 1;
        result := s[:p] + s2 + ((p + s1.Length <= s.Length) ? s[p + s1.Length:] : '');
    end
end;
function count(s: String; c: Char): Integer;
var
    i: Integer;
begin
    result := 0;
    for i := 1 to s.Length do
        if s[i] = c then
            result := result + 1;
end;
var
    n: Integer;
    s: String;
begin
    for n := 4 to 999 do
    begin
        s := '1' + '7' * n;
        while s.Contains('17') or s.Contains('377') or s.Contains('777') do
        begin
            if s.Contains('17') then
                s := replace(s, '17', '1');
            if s.Contains('377') then
                s := replace(s, '377', '73');
            if s.Contains('777') then
                s := replace(s, '777', '3');
        end;
        if count(s, '3') = 2 then
        begin
            Writeln(n);
            break;
        end;
    end;
end.
C++
#include <iostream>
using namespace std;
string replace(string s, string s1, string s2)
{
    int p = s.find(s1);
    if (p != -1)
        return s.substr(0, p) + s2 + s.substr(p + s1.length(), s.length() - p - s1.length());
    return s;
}
string mul(string s, int n)
{
    string res = "";
    for (int i = 0; i < n; i++)
        res += s;
    return res;
}
int count(string s, char c)
{
    int k = 0;
    for (int i = 0; i < s.length(); i++)
        if (s[i] == c)
            k++;
    return k;
}
int main()
{
    for (int n = 4; n < 1000; n++)
    {
        string s = "1" + mul("7", n);
        while (s.find("17") != -1 || s.find("377") != -1 || s.find("777") != -1)
        {
            if (s.find("17") != -1)
                s = replace(s, "17", "1");
            if (s.find("377") != -1)
                s = replace(s, "377", "73");
            if (s.find("777") != -1)
                s = replace(s, "777", "3");
        }
        if (count(s, '3') == 2)
        {
            cout << n << endl;
            break;
        }
    }
}
Ответ
9
