Программное решение задач ЕГЭ по информатике

Задача 6705. Источник: Поляков. Задание КИМ 5

Страница задачи 6705

(Е. Джобс) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом:

  1. Строится двоичная запись числа N.
  2. Если число N делится на 2, к двоичной записи справа дописывается 0, иначе справа дописывается 1.
  3. Если в двоичной записи числа N чётное число единиц, справа дописывается 0, иначе дописывается 1.
  4. Полученная таким образом запись является двоичной записью искомого числа R.

Например, для числа 13 двоичная запись 11012 преобразуется в запись 1101112 = 55, для числа 10 двоичная запись 10102 преобразуется в 1010002 = 40. Укажите минимальное значение R, большее чем 2023, которое может быть результатом работы алгоритма.

Решение

Традиционные решения через операции со строками и эквивалентные целочисленные операции.

Python через строки

mn = 10000
for n in range(1, 1000):
    s = bin(n)[2:]
    k = s.count('1')
    if s[-1] == '0':
        s += '0'
    else:
        s += '1'
    if k % 2 == 0:
        s += '0'
    else:
        s += '1'
    r = int(s, 2)
    if r > 2023:
        mn = min(mn, r)
print(mn)

Python через целочисленные операции

mn = 10000
for n in range(1, 1000):
    z = n
    k = 0
    while z > 0:
        k += z % 2
        z //= 2
    r = n * 2
    if n % 2 == 1:
        r += 1
    r *= 2
    if k % 2 == 1:
        r += 1
    if r > 2023:
        mn = min(mn, r)
print(mn)

PascalABC через строки

function Bin(n: Integer): String;
begin
    result := '';
    while n > 0 do
    begin
        result := IntToStr((n mod 2)) + result;
        n := n div 2;
    end;
    if result = '' then
        result := '0';
end;

function Int(s: String; r: Integer := 10): Integer;
var
    n, i: Integer;
begin
    result := 0;
    n := 1;
    for i := s.Length downto 1 do
    begin
        result := result + StrToInt(s[i]) * n;
        n := n * r;
    end;
end;

function Count(s: String; c: Char): Integer;
var
    i: Integer;
begin
    result := 0;
    for i := 1 to s.Length do
        if s[i] = c then
            result := result + 1;
end;

var
    n, r, k, min: Integer;
    s: String;
begin
    min := 10000;
    for n := 1 to 999 do
    begin
        s := Bin(n);
        k := Count(s, '1');
        if s[s.Length] = '0' then
            s := s + '0'
        else
            s := s + '1';
        if k mod 2 = 0 then
            s := s + '0'
        else
            s := s + '1';
        r := Int(s, 2);
        if (r > 2023) and (r < min) then
            min := r;
    end;
    Writeln(min);
end.

PascalABC через целочисленные операции

var
    n, r, z, k, min: Integer;
begin
    min := 10000;
    for n := 1 to 1000 do
    begin
        z := n;
        k := 0;
        while z > 0 do
        begin
            k := k + z mod 2;
            z := z div 2;
        end;
        r := n * 2;
        if n mod 2 = 1 then
            r := r + 1;
        r := r * 2;
        if k mod 2 = 1 then
            r := r + 1;
        if (r > 2023) and (r < min) then
            min := r;
    end;
    Writeln(min);
end.

C++ через строки

#include <iostream>
#include <string>
using namespace std;

string bin(int n)
{
    string s = "";
    while (n > 0)
    {
        s = to_string(n % 2) + s;
        n /= 2;
    }
    if (s == "")
        s = "0";
    return s;
}

int to_int(string s, int r)
{
    int n = 0, z = 1;
    for (int i = s.length() - 1; i >= 0; i--)
    {
        n += ((int)s[i] - 48) * z;
        z *= r;
    }
    return n;
}

int count(string s, char c)
{
    int n = 0;
    for (int i = 0; i < s.length(); i++)
        if (s[i] == c)
            n++;
    return n;
}

int main()
{
    int min = 10000;
    for (int n = 1; n < 1000; n++)
    {
        string s = bin(n);
        int k = count(s, '1');
        if (s[s.length() - 1] == '0')
            s += "0";
        else
            s += "1";
        if (k % 2 == 0)
            s += "0";
        else
            s += "1";
        int r = to_int(s, 2);
        if (r > 2023 && r < min)
            min = r;
    }
    cout << min << endl;
}

C++ через целочисленные операции

#include <iostream>
using namespace std;
int main()
{
    int min = 10000, r;
    for (int n = 1; n < 1000; n++)
    {
        int z = n, k = 0;
        while (z > 0)
        {
            k += z % 2;
            z /= 2;
        }
        r = n * 2;
        if (n % 2 == 1)
            r += 1;
        r *= 2;
        if (k % 2 == 1)
            r += 1;
        if (r > 2023 && r < min)
            min = r;
    }
    cout << min << endl;
}

Ответ

2025

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: