Программное решение задач ЕГЭ по информатике

Задача 6676. Источник: Поляков. Задание КИМ 24

Страница задачи 6676

(ЕГЭ-2023) Текстовый файл 24-264.txt состоит не более чем из 106 символов и содержит только заглавные буквы латинского алфавита и цифры. Определите максимальную длину подстроки, которая может являться записью числа в шестнадцатеричной системе счисления.

Решение

Классическая посимвольная обработка строки. Если символ является цифрой шестнадцатеричной системы счисления, увеличиваем счетчик и обрабатываем его на возможный максимум, иначе счетчик сбрасываем в нулевое значение.

Python

s = open('24-264.txt').readline()
k = 0
mx = 0
for i in s:
    if '0' <= i <= 'F':
        k += 1
        mx = max(mx, k)
    else:
        k = 0
print(mx)

PascalABC

var
    i, k, max: Integer;
    s: String;
    f: TEXT;
begin
    Assign(f, '24-264.txt');
    Reset(f);
    Readln(f, s);
    k := 0;
    max := 0;
    for i := 1 to s.Length do
        if (s[i] >= '0') and (s[i] <= 'F') then
        begin
            k := k + 1;
            if k > max then
                max := k;
        end
        else
            k := 0;
    Writeln(max);
end.

C++

#include <iostream>
#include <fstream>
using namespace std;
int main()
{
    ifstream f;
    f.open("24-264.txt");
    string s;
    f >> s;
    int k = 0, max = 0;
    for (int i = 0; i < s.length(); i++)
        if (s[i] >= '0' && s[i] <= 'F')
        {
            k++;
            if (k > max)
                max = k;
        }
        else
            k = 0;
    cout << max << endl;
}

Ответ

34

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: