Программное решение задач ЕГЭ по информатике

Задача 6576. Источник: Поляков. Задание КИМ 5

Страница задачи 6576

(А. Богданов) Назовём битом чётности остаток от деления числа единиц двоичной записи на 2. На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом:

  1. Строится двоичная запись числа N.
  2. Если число N четное, то к двоичному представлению слева дописывается 1, а справа бит четности числа N; если число нечетное, то к двоичному представлению справа дописывается 0 и затем бит четности числа N.
  3. Полученная таким образом запись является двоичной записью искомого числа R.

Например, для исходного числа 12 = 11002 результатом является число 1110002 = 56, а для исходного числа 5 = 1012 результатом является число 101002 = 20. Укажите число N, после обработки которого с помощью этого алгоритма получается минимальное число R, большее 100.

Решение

Задачу можно решать через строки или эквивалентные целочисленные операции. Поскольку в C++ и PascalABC нет стандартных функций преобразования систем счисления, для решения через строки такие функции придется создать, что значительно увеличивает объем кода.

Python через строки

mn = 1000
mnn = 0
for n in range(1, 100):
    s = bin(n)[2:]
    if s[-1] == '0':
        s = '1' + s + str(s.count('1') % 2)
    else:
        s += '0' + str(s.count('1') % 2)
    r = int(s, 2)
    if r > 100 and r < mn:
        mn = r
        mnn = n
print(mnn)

Python через целочисленные операции

mn = 1000
mnn = 0
for n in range(1, 100):
    k = 0
    z = n
    while z > 0:
        k += z % 2
        z //= 2
    if n % 2 == 0:
        z = 1
        while z <= n:
            z *= 2
        r = (z + n) * 2 + k % 2
    else:
        r = n * 4 + k % 2
    if r > 100 and r < mn:
        mn = r
        mnn = n
print(mnn)

PascalABC через строки

function Bin(n: Integer): String;
begin
    result := '';
    while n > 0 do
    begin
        result := IntToStr((n mod 2)) + result;
        n := n div 2;
    end;
    if result = '' then
        result := '0';
end;

function Int(s: String; r: Integer := 10): Integer;
var
    n, i: Integer;
begin
    result := 0;
    n := 1;
    for i := s.Length downto 1 do
    begin
        result := result + StrToInt(s[i]) * n;
        n := n * r;
    end;
end;

function Count(s: String; c: Char): Integer;
var
    i: Integer;
begin
    result := 0;
    for i := 1 to s.Length do
        if s[i] = c then
            result := result + 1;
end;

var
    n, min, minn, r: Integer;
    s: String;
begin
    min := 1000;
    minn := 0;
    for n := 1 to 99 do
    begin
        s := Bin(n);
        if s[s.Length] = '0' then
            s := '1' + s + IntToStr((Count(s, '1') mod 2))
        else
            s := s + '0' + IntToStr((Count(s, '1') mod 2));
        r := Int(s, 2);
        if (r > 100) and (r < min) then
        begin
            min := r;
            minn := n;
        end;
    end;
    Writeln(minn);
end.

PascalABC через целочисленные операции

var
    n, min, minn, r, k, z: Integer;
begin
    min := 1000;
    minn := 0;
    for n := 1 to 99 do
    begin
        k := 0;
        z := n;
        while z > 0 do
        begin
            k := k + z mod 2;
            z := z div 2;
        end;
        if n mod 2 = 0 then
        begin
            z := 1;
            while z <= n do
                z := z * 2;
            r := (z + n) * 2 + k mod 2;
        end
        else
            r := n * 4 + k mod 2;
        if (r > 100) and (r < min) then
        begin
            min := r;
            minn := n;
        end;
    end;
    Writeln(minn);
end.

C++ через строки

#include <iostream>
#include <string>
using namespace std;

string bin(int n)
{
    string s = "";
    while (n > 0)
    {
        s = to_string(n % 2) + s;
        n /= 2;
    }
    if (s == "")
        s = "0";
    return s;
}

int to_int(string s, int r)
{
    int n = 0, z = 1;
    for (int i = s.length() - 1; i >= 0; i--)
    {
        n += ((int)s[i] - 48) * z;
        z *= r;
    }
    return n;
}

int count(string s, char c)
{
    int n = 0;
    for (int i = 0; i < s.length(); i++)
        if (s[i] == c)
            n++;
    return n;
}

int main()
{
    int min = 1000, minn = 0;
    for (int n = 1; n < 100; n++)
    {
        string s = bin(n);
        if (s[s.length() - 1] == '0')
            s = '1' + s + to_string(count(s, '1') % 2);
        else
            s += '0' + to_string(count(s, '1') % 2);
        int r = to_int(s, 2);
        if (r > 100 && r < min)
        {
            min = r;
            minn = n;
        }
    }
    cout << minn << endl;
}

C++ через целочисленные операции

#include <iostream>
using namespace std;
int main()
{
    int min = 1000, minn = 0;
    for (int n = 1; n < 100; n++)
    {
        int k = 0, z = n, r = 0;
        while (z > 0)
        {
            k += z % 2;
            z /= 2;
        }
        if (n % 2 == 0)
        {
            z = 1;
            while (z <= n)
                z *= 2;
            r = (z + n) * 2 + k % 2;
        }
        else
            r = n * 4 + k % 2;
        if (r > 100 && r < min)
        {
            min = r;
            minn = n;
        }
    }
    cout << minn << endl;
}

Ответ

25

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: