Программное решение задач ЕГЭ по информатике

Задача 6317. Источник: Поляков. Задание КИМ 26

Страница задачи 6317

(Л. Евич) В операционном зале есть N банкоматов, работающих круглосуточно. Все банкоматы пронумерованы. В течение дня M клиентов хотят воспользоваться банкоматом. Клиенты обслуживаются в порядке общей очереди. Если в один момент подошли несколько клиентов, то они становятся в очередь в порядке расположения данных в файле. Клиент, стоящий первым в очереди, подходит к первому освободившемуся банкомату (если таких несколько – к банкомату с наименьшим номером). Обслуживание очередного клиента может начаться в ту же минуту, когда банкомат станет свободным. Известно время в минутах от начала суток, когда клиент подошёл к банкомату, и время его обслуживания.

Определите количество клиентов, которые могли быть обслужены банкоматами за 24 часа и номер банкомата, в котором обслуживался последний клиент. Последним обслуженным клиентом считается тот, который подошёл к банкомату до окончания суток (его обслуживание могло закончиться в следующие сутки).

Входные данные представлены в файле 26-112.txt следующим образом. В первой строке входных данных задается два числа: N - количество банкоматов и M – количество клиентов. В каждой из последующих M строк содержится информация по одному клиенту: время начала обслуживания клиента (в минутах с начала суток) и время обслуживания (в минутах).

Запишите в ответе два числа: количество клиентов, которые смогут воспользоваться банкоматом, и номер банкомата, в котором обслуживался последний клиент.

Пример входного файла:
2 5
1 8
6 12
8 4
8 14
8 9

Пусть максимальное время обслуживания равно 15 минутам. При таких исходных данных клиенты обслуживаются следующим образом. 1-й банкомат: клиенты со временем обслуживания 8, 4, 14; 2-й банкомат: клиент со временем обслуживания 12. Клиента со временем 9 обслужить за 15 минут не удаётся. Последний обслуженный клиент (со временем 14) начинает работу с 1-м банкоматом на 13-й минуте. Ответ: 4 1.

Решение

Считываем исходные данные в двухмерный массив/список и сортируем их строго по времени подхода. Для сортировки обязательно применять стабильный алгоритм сортировки(сортировка вставкой или пузырьком), чтобы не нарушать порядок клиентов с одинаковым временем подхода. Создадим массив/список atms, где будем хранить время освобождения каждого банкомата. В переменной k будем подсчитывать количество обслуженных клиентов за 24 часа, а в переменной last - номер банкомата, где обслуживался последний клиент. Для каждого клиента находим свободный к моменту визита банкомат с минимальным номером, а при отсутствии такового, с наименьшим временем освобождения. Если это время входит в первые сутки, увеличиваем счетчик клиентов и обновляем значение last. После обработки всех клиентов выводим результат.

Python

f = open('26-112.txt')
n, m = map(int, f.readline().split())
a = [[int(y) for y in x.split()] for x in f]
a.sort(key=lambda x: x[0])
atms = [0] * n
k = 0
last = 0
for i in a:
    atm = 0
    for j in range(1, n):
        if atms[j] < atms[atm] and atms[atm] > i[0]:
            atm = j
    if atms[atm] <= 1440:
        last = atm + 1
        k += 1
    atms[atm] = max(atms[atm], i[0]) + i[1]
print(k, last)

PascalABC

var
    n, m, k, last, atm, i, j, t: Integer;
    a: array [1..3500, 1..2] of Integer;
    atms: array [1..20] of Integer;
    f: TEXT;
begin
    Assign(f, '26-112.txt');
    Reset(f);
    Readln(f, n, m);
    for i := 1 to m do
        Readln(f, a[i, 1], a[i, 2]);
    for i := 1 to m - 1 do
        for j := m downto i + 1 do
            if a[j, 1] < a[j - 1, 1] then
            begin
                t := a[j, 1];
                a[j, 1] := a[j - 1, 1];
                a[j - 1, 1] := t;
                t := a[j, 2];
                a[j, 2] := a[j - 1, 2];
                a[j - 1, 2] := t;
            end;
    for i := 1 to n do
        atms[i] := 0;
    k := 0;
    last := 0;
    for i := 1 to m do
    begin
        atm := 1;
        for j := 2 to n do
            if (atms[j] < atms[atm]) and (atms[atm] > a[i, 1]) then
                atm := j;
        if atms[atm] <= 1440 then
        begin
            last := atm;
            k := k + 1;
        end;
        if atms[atm] > a[i, 1] then
            atms[atm] := atms[atm] + a[i, 2]
        else
            atms[atm] := a[i, 1] + a[i, 2];
    end;
    Writeln(k, ' ', last);
end.

C++

#include <iostream>
#include <fstream>
using namespace std;
int main()
{
    ifstream f;
    f.open("26-112.txt");
    int n, m;
    f >> n >> m;
    int a[3500][2];
    for (int i = 0; i < m; i++)
        f >> a[i][0] >> a[i][1];
    for (int i = 0; i < m - 1; i++)
        for (int j = m - 1; j > i; j--)
            if (a[j][0] < a[j - 1][0])
            {
                int t = a[j][0];
                a[j][0] = a[j - 1][0];
                a[j - 1][0] = t;
                t = a[j][1];
                a[j][1] = a[j - 1][1];
                a[j - 1][1] = t;
            }
    int atms[20];
    for (int i = 0; i < n; i++)
        atms[i] = 0;
    int k = 0, last = 0;
    for (int i = 0; i < m; i++)
    {
        int atm = 0;
        for (int j = 1; j < n; j++)
            if (atms[j] < atms[atm] && atms[atm] > a[i][0])
                atm = j;
        if (atms[atm] <= 1440)
        {
            last = atm + 1;
            k++;
        }
        if (atms[atm] > a[i][0])
            atms[atm] += a[i][1];
        else
            atms[atm] = a[i][0] + a[i][1];
    }
    cout << k << " " << last << endl;
}

Ответ

1591 4

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: