Программное решение задач ЕГЭ по информатике

Задача 6282. Источник: Поляков. Задание КИМ 5

Страница задачи 6282

(PRO100 ЕГЭ) На вход алгоритма подаётся натуральное число N (N > 3). Алгоритм строит по нему новое число R следующим образом:

  1. Строится двоичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    1. если N делится на 3, то в конец этой записи дописывается три последние цифры двоичной записи;
    2. если N не делится на 3, то остаток при делении на 3 числа N умножается на 3, переводится в двоичную запись и дописывается в конец двоичной записи числа N.
  3. Полученная таким образом запись является двоичной записью искомого числа R.

Например, для исходного числа 1210 = 11002 результатом является число 11001002 = 10010, а для исходного числа 410 = 1002 результатом является число 100112 = 1910.

Найдите максимальное число R, меньшее, чем 68, которое может получится в результате работы алгоритма. В ответе запишите это число в десятичной системе счисления.

Решение

Перебирая значения n, найдем ответ на вопрос. Алгоритм может быть реализован, как через эквивалентные целочисленные операции, так и через операции со строками.

Python через строки

mx = 0
for n in range(4, 100):
    s = bin(n)[2:]
    if n % 3 == 0:
        s += s[-3:]
    else:
        s += bin(n % 3 * 3)[2:]
    r = int(s, 2)
    if r < 68:
        mx = max(mx, r)
print(mx)

Python через целочисленные операции

mx = 0
for n in range(4, 100):
    if n % 3 == 0:
        r = n * 8 + n % 8
    else:
        z = n % 3 * 3
        m = 2
        while m <= z:
            m *= 2
        r = n * m + z
    if r < 68:
        mx = max(mx, r)
print(mx)

PascalABC через строки

function Bin(n: Integer): String;
begin
    result := '';
    while n > 0 do
    begin
        result := IntToStr((n mod 2)) + result;
        n := n div 2;
    end;
    if result = '' then
        result := '0';
end;

function Int(s: String; r: Integer := 10): Integer;
var
    n, i: Integer;
begin
    result := 0;
    n := 1;
    for i := s.Length downto 1 do
    begin
        result := result + StrToInt(s[i]) * n;
        n := n * r;
    end;
end;

var
    n, max, r: Integer;
    s: String;
begin
    max := 0;
    for n := 4 to 99 do
    begin
        s := Bin(n);
        if n mod 3 = 0 then
            s := s + s[s.Length - 2:]
        else
            s := s + Bin(n mod 3 * 3);
        r := Int(s, 2);
        if (r < 68) and (r > max) then
            max := r;
    end;
    Writeln(max);
end.

PascalABC через целочисленные операции

var
    n, r, max, z, m: Integer;
begin
    max := 0;
    for n := 4 to 99 do
    begin
        if n mod 3 = 0 then
            r := n * 8 + n mod 8
        else
        begin
            z := n mod 3 * 3;
            m := 2;
            while m <= z do
                m := m * 2;
            r := n * m + z;
        end;
        if (r < 68) and (r > max) then
            max := r;
    end;
    Writeln(max);
end.

C++ через строки

#include <iostream>
#include <string>
using namespace std;

string bin(int n)
{
    string s = "";
    while (n > 0)
    {
        s = to_string(n % 2) + s;
        n /= 2;
    }
    if (s == "")
        s = "0";
    return s;
}

int to_int(string s, int r)
{
    int n = 0, z = 1;
    for (int i = s.length() - 1; i >= 0; i--)
    {
        n += ((int)s[i] - 48) * z;
        z *= r;
    }
    return n;
}

int main()
{
    int max = 0;
    for (int n = 4; n < 100; n++)
    {
        string s = bin(n);
        if (n % 3 == 0)
            s += s.substr(s.length() - 3, 3);
        else
            s += bin(n % 3 * 3);
        int r = to_int(s, 2);
        if (r < 68 && r > max)
            max = r;
    }
    cout << max << endl;
}

C++ через целочисленные операции

#include <iostream>
using namespace std;
int main()
{
    int max = 0;
    for (int n = 4; n < 100; n++)
    {
        int r;
        if (n % 3 == 0)
            r = n * 8 + n % 8;
        else
        {
            int z = n % 3 * 3;
            int m = 2;
            while (m <= z)
                m *= 2;
            r = n * m + z;
        }
        if (r < 68 && r > max)
            max = r;
    }
    cout << max << endl;
}

Ответ

67

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: