Программное решение задач ЕГЭ по информатике

Задача 6281. Источник: Поляков. Задание КИМ 5

Страница задачи 6281

(PRO100 ЕГЭ) На вход алгоритма подаётся натуральное число N (N > 3). Алгоритм строит по нему новое число R следующим образом:

  1. Строится двоичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    1. если N делится на 4, то в конец этой записи дописывается две последние цифры двоичной записи;
    2. если N не делится на 4, то остаток от деления N на 4 умножается на 2 в двоичной системе счисления и дописывается в начало двоичной записи числа N.
  3. Полученная таким образом запись является двоичной записью искомого числа R.

Например, для исходного числа 1210 = 11002 результатом является число 1100002 = 4810, а для исходного числа 1010 = 10102 результатом является число 10010102 = 7410.

Укажите максимальное число N, после обработки которого с помощью этого алгоритма получается число R, меньшее 68. В ответе запишите это число в десятичной системе счисления.

Решение

Традиционные для данной темы решения задачи через эквивалентные целочисленные операции и через строки.

Python через целочисленные операции

mx = 0
for n in range(4, 100):
    if n % 4 == 0:
        r = n * 4 + n % 4
    else:
        z = n % 4 * 2
        m = 2
        while m <= z:
            m *= 2
        r = n * m + z
    if r < 68:
        mx = n
print(mx)

Python через строки

mx = 0
for n in range(4, 100):
    s = bin(n)[2:]
    if n % 4 == 0:
        s += s[-2:]
    else:
        s += bin(n % 4 * 2)[2:]
    r = int(s, 2)
    if r < 68:
        mx = n
print(mx)

PascalABC через целочисленные операции

var
    n, r, max, z, m: Integer;
begin
    max := 0;
    for n := 4 to 99 do
    begin
        if n mod 4 = 0 then
            r := n * 4 + n mod 4
        else
        begin
            z := n mod 4 * 2;
            m := 2;
            while m <= z do
                m := m * 2;
            r := n * m + z;
        end;
        if r < 68 then
            max := n;
    end;
    Writeln(max);
end.

PascalABC через строки

function Bin(n: Integer): String;
begin
    result := '';
    while n > 0 do
    begin
        result := IntToStr((n mod 2)) + result;
        n := n div 2;
    end;
    if result = '' then
        result := '0';
end;

function Int(s: String; r: Integer := 10): Integer;
var
    n, i: Integer;
begin
    result := 0;
    n := 1;
    for i := s.Length downto 1 do
    begin
        result := result + StrToInt(s[i]) * n;
        n := n * r;
    end;
end;

var
    n, max, r: Integer;
    s: String;
begin
    max := 0;
    for n := 4 to 99 do
    begin
        s := Bin(n);
        if n mod 4 = 0 then
            s := s + s[s.Length - 1:]
        else
            s := s + Bin(n mod 4 * 2);
        r := Int(s, 2);
        if r < 68 then
            max := n;
    end;
    Writeln(max);
end.

C++ через целочисленные операции

#include <iostream>
using namespace std;
int main()
{
    int max = 0;
    for (int n = 4; n < 100; n++)
    {
        int r;
        if (n % 4 == 0)
            r = n * 4 + n % 4;
        else
        {
            int z = n % 4 * 2;
            int m = 2;
            while (m <= z)
                m *= 2;
            r = n * m + z;
        }
        if (r < 68)
            max = n;
    }
    cout << max << endl;
}

C++ через строки

#include <iostream>
#include <string>
using namespace std;

string bin(int n)
{
    string s = "";
    while (n > 0)
    {
        s = to_string(n % 2) + s;
        n /= 2;
    }
    if (s == "")
        s = "0";
    return s;
}

int to_int(string s, int r)
{
    int n = 0, z = 1;
    for (int i = s.length() - 1; i >= 0; i--)
    {
        n += ((int)s[i] - 48) * z;
        z *= r;
    }
    return n;
}

int main()
{
    int max = 0;
    for (int n = 4; n < 100; n++)
    {
        string s = bin(n);
        if (n % 4 == 0)
            s += s.substr(s.length() - 2, 2);
        else
            s += bin(n % 4 * 2);
        int r = to_int(s, 2);
        if (r < 68)
            max = n;
    }
    cout << max << endl;
}

Ответ

16

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: