Программное решение задач ЕГЭ по информатике

Задача 6255. Источник: Поляков. Задание КИМ 5

Страница задачи 6255

(PRO100 ЕГЭ) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом:

  1. Строится двоичная запись числа N.
  2. Далее эта запись обрабатывается по следующему правилу:
    1. если сумма цифр в двоичной записи числа чётная, то к этой записи справа дописывается 0, а затем три левых разряда заменяются на 101;
    2. если сумма цифр в двоичной записи числа нечётная, то к этой записи справа дописывается 11, а затем два левых разряда заменяются на 10.
  3. Полученная таким образом запись является двоичной записью искомого числа R.

Например, для исходного числа 610 = 1102 результатом является число 10102 = 1010, а для исходного числа 410 = 1002 результатом является число 100112 = 1910.

Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, большее 68. В ответе запишите это число в десятичной системе счисления.

Решение

Задачи с заменой разрядов проще решаются через операции со строками, но они могут быть решены и через эквивалентные целочисленные операции. Для реализации такого решения требуется отличное понимание систем счисления и операций в них.

Python через строки

for n in range(4, 100):
    s = bin(n)[2:]
    if s.count('1') % 2 == 0:
        s += '0'
        s = '101' + s[3:]
    else:
        s = '10' + s[2:] + '11'
    r = int(s, 2)
    if r > 68:
        print(n)
        break

Python через целочисленные операции

for n in range(4, 100):
    z = n
    k = 0
    while z > 0:
        k += z % 2
        z //= 2
    if k % 2 == 0:
        z = n * 2
        k = 0
        while z > 7:
            k += 1
            z //= 2
        r = n * 2 - z * 2 ** k + 5 * 2 ** k
    else:
        z = n * 4 + 3
        k = 0
        while z > 3:
            k += 1
            z //= 2
        r = n * 4 + 3 - z * 2 ** k + 2 * 2 ** k
    if r > 68:
        print(n)
        break

PascalABC через строки

function Bin(n: Integer): String;
begin
    result := '';
    while n > 0 do
    begin
        result := IntToStr((n mod 2)) + result;
        n := n div 2;
    end;
    if result = '' then
        result := '0';
end;

function Int(s: String; r: Integer := 10): Integer;
var
    n, i: Integer;
begin
    result := 0;
    n := 1;
    for i := s.Length downto 1 do
    begin
        result := result + StrToInt(s[i]) * n;
        n := n * r;
    end;
end;

function Count(s: String; c: Char): Integer;
var
    i: Integer;
begin
    result := 0;
    for i := 1 to s.Length do
        if s[i] = c then
            result := result + 1;
end;

var
    n, r: Integer;
    s: String;
begin
    for n := 4 to 99 do
    begin
        s := Bin(n);
        if Count(s, '1') mod 2 = 0 then
        begin
            s := s + '0';
            s := '101' + s[4:];
        end
        else
            s := '10' + s[3:] + '11';
        r := Int(s, 2);
        if r > 68 then
        begin
            Writeln(n);
            break;
        end;
    end;
end.

PascalABC через целочисленные операции

var
    n, r, z, k: Integer;
begin
    for n := 4 to 99 do
    begin
        z := n;
        k := 0;
        while z > 0 do
        begin
            k := k + z mod 2;
            z := z div 2;
        end;
        if k mod 2 = 0 then
        begin
            z := n * 2;
            k := 0;
            while z > 7 do
            begin
                k := k + 1;
                z := z div 2;
            end;
            r := n * 2 - z * round(power(2, k)) + 5 * round(power(2, k));
        end
        else
        begin
            z := n * 4 + 3;
            k := 0;
            while z > 3 do
            begin
                k := k + 1;
                z := z div 2;
            end;
            r := n * 4 + 3 - z * round(power(2, k)) + 2 * round(power(2, k));
        end;
        if r > 68 then
        begin
            Writeln(n);
            break;
        end;
    end;
end.

C++ через строки

#include <iostream>
#include <string>
using namespace std;

string bin(int n)
{
    string s = "";
    while (n > 0)
    {
        s = to_string(n % 2) + s;
        n /= 2;
    }
    if (s == "")
        s = "0";
    return s;
}

int to_int(string s, int r)
{
    int n = 0, z = 1;
    for (int i = s.length() - 1; i >= 0; i--)
    {
        n += ((int)s[i] - 48) * z;
        z *= r;
    }
    return n;
}

int count(string s, char c)
{
    int n = 0;
    for (int i = 0; i < s.length(); i++)
        if (s[i] == c)
            n++;
    return n;
}

int main()
{
    for (int n = 4; n < 100; n++)
    {
        string s = bin(n);
        if (count(s, '1') % 2 == 0)
        {
            s += "0";
            s = "101" + s.substr(3, s.length() - 3);
        }
        else
            s = "10" + s.substr(2, s.length() - 2) + "11";
        int r = to_int(s, 2);
        if (r > 68)
        {
            cout << n << endl;
            break;
        }
    }
}

C++ через целочисленные операции

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    for (int n = 4; n < 100; n++)
    {
        int z = n, k = 0, r;
        while (z > 0)
        {
            k += z % 2;
            z /= 2;
        }
        if (k % 2 == 0)
        {
            z = n * 2;
            k = 0;
            while (z > 7)
            {
                k++;
                z /= 2;
            }
            r = n * 2 - z * (int)pow(2, k) + 5 * (int)pow(2, k);
        }
        else
        {
            z = n * 4 + 3;
            k = 0;
            while (z > 3)
            {
                k++;
                z /= 2;
            }
            r = n * 4 + 3 - z * (int)pow(2, k) + 2 * (int)pow(2, k);
        }
        if (r > 68)
        {
            cout << n << endl;
            break;
        }
    }
}

Ответ

19

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: