Программное решение задач ЕГЭ по информатике

Задача 5823. Источник: Поляков. Задание КИМ 14

Страница задачи 5823

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

13132x4 – 13x4222

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором абсолютное значение данного арифметического выражения при делении на 100 даёт остаток 53. Для найденного значения x вычислите целое частное от деления абсолютного значения арифметического выражения на 100 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

В данной задаче возможные значения X лежат в диапазоне от 0 до 9.

Python

result = 0
for x in range(10):
    n1 = 13204 + x * 10 + 3
    n2 = 22 ** 4 + 3 * 22 ** 3 + x * 22 ** 2 + 4 * 22 + 2
    n = n1 - n2
    if abs(n) % 100 == 53:
        result = abs(n) // 100
print(result)

PascalABC

var
    x, n, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        n1 := 13204 + x * 10 + 3;
        n2 := trunc(power(22, 4)) + 3 * trunc(power(22, 3)) +
              x * trunc(power(22, 2)) + 4 * 22 + 2;
        n := n1 - n2;
        if abs(n) mod 100 = 53 then
            r := abs(n) div 100;
    end;
    Writeln(r);
end.

C++

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int n1 = 13204 + x * 10 + 3;
        int n2 = (int)pow(22, 4) + 3 * (int)pow(22, 3) +
                 x * (int)pow(22, 2) + 4 * 22 + 2;
        int n = n1 - n2;
        if (abs(n) % 100 == 53)
            r = abs(n) / 100;
    }
    cout << r << endl;
}

Ответ

2554

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: