Программное решение задач ЕГЭ по информатике

Задача 5821. Источник: Поляков. Задание КИМ 14

Страница задачи 5821

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

13132x4 – 134x213

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 30. Для найденного значения x вычислите частное от деления абсолютного значения арифметического выражения на 30 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    n1 = 13204 + x * 10 + 3
    n2 = 13 ** 4 + 3 * 13 ** 3 + 4 * 13 ** 2 + x * 13 + 2
    n = n1 - n2
    if abs(n) % 30 == 0:
        result = abs(n) // 30
print(result)

PascalABC

var
    x, n, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        n1 := 13204 + x * 10 + 3;
        n2 := trunc(power(13, 4)) + 3 * trunc(power(13, 3)) +
              4 * trunc(power(13, 2)) + x * 13 + 2;
        n := n1 - n2;
        if abs(n) mod 30 = 0 then
            r := abs(n) div 30;
    end;
    Writeln(r);
end.

C++

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int n1 = 13204 + x * 10 + 3;
        int n2 = (int)pow(13, 4) + 3 * (int)pow(13, 3) +
            4 * (int)pow(13, 2) + x * 13 + 2;
        int n = n1 - n2;
        if (abs(n) % 30 == 0)
            r = abs(n) / 30;
    }
    cout << r << endl;
}

Ответ

755

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: