Программное решение задач ЕГЭ по информатике

Задача 5819. Источник: Поляков. Задание КИМ 14

Страница задачи 5819

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

134x219 + 2613x24

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 15. Для найденного значения x вычислите частное от деления значения арифметического выражения на 15 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    n1 = 19 ** 4 + 3 * 19 ** 3 + 4 * 19 ** 2 + x * 19 + 2
    n2 = 2 * (13024 + x * 100) + 6
    n = n1 + n2
    if n % 15 == 0:
        result = n // 15
print(result)

PascalABC

var
    x, n, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        n1 := trunc(power(19, 4)) + 3 * trunc(power(19, 3)) +
              4 * trunc(power(19, 2)) + x * 19 + 2;
        n2 := 2 * (13024 + x * 100) + 6;
        n := n1 + n2;
        if n mod 15 = 0 then
            r := n div 15;
    end;
    Writeln(r);
end.

C++

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int n1 = (int)pow(19, 4) + 3 * (int)pow(19, 3) +
            4 * (int)pow(19, 2) + x * 19 + 2;
        int n2 = 2 * (13024 + x * 100) + 6;
        int n = n1 + n2;
        if (n % 15 == 0)
            r = n / 15;
    }
    cout << r << endl;
}

Ответ

12010

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: