Программное решение задач ЕГЭ по информатике

Задача 5818. Источник: Поляков. Задание КИМ 14

Страница задачи 5818

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

141x324 + 13x4224

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 10. Для найденного значения x вычислите частное от деления значения арифметического выражения на 10 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    n1 = 10324 + x * 1000 + 4
    n2 = 24 ** 4 + 3 * 24 ** 3 + x * 24 ** 2 + 4 * 24 + 2
    n = n1 + n2
    if n % 10 == 0:
        result = n // 10
print(result)

PascalABC

var
    x, n, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        n1 := 10324 + x * 1000 + 4;
        n2 := trunc(power(24, 4)) + 3 * trunc(power(24, 3)) +
              x * trunc(power(24, 2)) + 4 * 24 + 2;
        n := n1 + n2;
        if n mod 10 = 0 then
            r := n div 10;
    end;
    Writeln(r);
end.

C++

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int n1 = 10324 + x * 1000 + 4;
        int n2 = (int)pow(24, 4) + 3 * (int)pow(24, 3) +
            x * (int)pow(24, 2) + 4 * 24 + 2;
        int n = n1 + n2;
        if (n % 10 == 0)
            r = n / 10;
    }
    cout << r << endl;
}

Ответ

39313

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: