Программное решение задач ЕГЭ по информатике

Задача 5816. Источник: Поляков. Задание КИМ 14

Страница задачи 5816

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

103123x4 + 10212x43

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 50. Для найденного значения x вычислите частное от деления значения арифметического выражения на 50 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    r1 = 12304 + x * 10
    r2 = 12043 + x * 100
    n1 = r1 ** 2 + 3
    n2 = r2 ** 2 + 2
    n = n1 + n2
    if n % 50 == 0:
        result = n // 50
print(result)

PascalABC

var
    x, n, r1, r2, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        r1 := 12304 + x * 10;
        r2 := 12043 + x * 100;
        n1 := r1 * r1 + 3;
        n2 := r2 * r2 + 2;
        n := n1 + n2;
        if n mod 50 = 0 then
            r := n div 50;
    end;
    Writeln(r);
end.

C++

#include <iostream>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int r1 = 12304 + x * 10;
        int r2 = 12043 + x * 100;
        int n1 = r1 * r1 + 3;
        int n2 = r2 * r2 + 2;
        int n = n1 + n2;
        if (n % 50 == 0)
            r = n / 50;
    }
    cout << r << endl;
}

Ответ

6254279

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: