Программное решение задач ЕГЭ по информатике

Задача 5646. Источник: Поляков. Задание КИМ 24

Страница задачи 5646

(П. Финкель) Текстовый файл 24-230.txt состоит не более чем из 106 символов и содержит буквы английского алфавита и цифры. Определите максимальное число в этом файле, ограниченное двумя парами символов KK и удовлетворяющее маске «43??78???34», где символ ? обозначает любую цифру. Пример такого числа: 43127812334. Найдите произведение нечётных цифр найденного числа.

Решение

Данную задачу не следует решать с использованием метода split, т.к. файл может содержать (и содержит) комбинации из трех букв K, которые не будут корректно обработаны данным методом. В данном файле комбинация KKK есть и перед числом, удовлетворяющим шаблону. Корректным решением будет использование средств поиска подстроки или посимвольная обработка. Идем от одной комбинации KK к другой, пока вся строка не будет обработана. Подстроку между комбинациями анализируем на соответствие числовому шаблону, выбирая максимальное число. Поскольку все числа имеют одинаковую длину, сравнивать их можно, как строки, не переводя в числа. Не забывайте, что при решении с переводом в число, следует использовать 64-разрядный целый тип.

Python с использованием метода поиска

s = open('24-230.txt').readline()
mx = ''
start = s.find('KK')
while (start != -1):
    finish = s.find('KK', start + 1)
    if finish != -1:
        s1 = s[start + 2: finish]
        if len(s1) == 11 and s1.isdigit():
            if s1[:2] == '43' and s1[4:6] == '78' and s1[9:] == '34':
                mx = max(mx, s1)
    start = finish
m = 1
for c in mx:
    if int(c) % 2 == 1:
        m *= int(c)
print(m)

Python с посимвольной обработкой

s = open('24-230.txt').readline()
mx = ''
last = -1
for i in range(len(s) - 1):
    if s[i] == 'K' and s[i + 1] == 'K':
        if last != - 1:
            s1 = s[last + 2:i]
            if len(s1) == 11 and s1.isdigit():
                if s1[:2] == '43' and s1[4:6] == '78' and s1[9:] == '34':
                    mx = max(mx, s1)
        last = i
m = 1
for c in mx:
    if int(c) % 2 == 1:
        m *= int(c)
print(m)

PascalABC с использованием метода поиска

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
      if not c.IsDigit() then
      begin
            result := False;
            break;
      end;
end;

var
    start, finish, m: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-230.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    start := s.IndexOf('KK');
    while start <> -1 do
    begin
        finish := s.IndexOf('KK', start + 1);
        if finish <> -1 then
        begin
            s1 := s[start + 3:finish + 1];
            if (s1.Length = 11) and IsDigit(s1) then
                if (s1[:3] = '43') and (s1[5:7] = '78') and (s1[10:] = '34') then
                    if s1 > max then
                        max := s1;
        end;
        start := finish;
    end;
    m := 1;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            m := m * (ord(c) - 48);
    Writeln(m);
end.

PascalABC с посимвольной обработкой

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
        if not c.IsDigit() then
        begin
            result := False;
            break;
        end;
end;

var
    last, i, m: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-230.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    last := -1;
    for i := 1 to s.Length - 1 do
        if (s[i] = 'K') and (s[i + 1] = 'K') then
        begin
            if last <> -1 then
            begin
                s1 := s[last + 2:i];
                if (s1.Length = 11) and IsDigit(s1) then
                    if (s1[:3] = '43') and (s1[5:7] = '78') and (s1[10:] = '34') then
                        if s1 > max then
                            max := s1;
            end;
            last := i;
        end;
    m := 1;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            m := m * (ord(c) - 48);
    Writeln(m);
end.

C++ с использованием метода поиска

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-230.txt");
    string s, max = "";
    f >> s;
    int start = s.find("KK");
    while (start != -1)
    {
        int finish = s.find("KK", start + 1);
        if (finish != -1)
        {
            string s1 = s.substr(start + 2, finish - start - 2);
            if (s1.length() == 11 and isdigit(s1))
                if (s1.substr(0, 2) == "43" && s1.substr(4, 2) == "78" && s1.substr(9, 2) == "34")
                    if (s1 > max)
                        max = s1;
        }
        start = finish;
    }
    int m = 1;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            m *= (int)max[i] - 48;
    cout << m << endl;
}

C++ с посимвольной обработкой

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-230.txt");
    string s, max = "";
    f >> s;
    int last = -1;
    for (int i = 0; i < s.length() - 1; i++)
        if (s[i]== 'K' && s[i + 1] == 'K')
        {
            if (last != -1)
            {
                string s1 = s.substr(last + 2, i - last - 2);
                if (s1.length() == 11 and isdigit(s1))
                    if (s1.substr(0, 2) == "43" && s1.substr(4, 2) == "78" && s1.substr(9, 2) == "34")
                        if (s1 > max)
                            max = s1;
            }
            last = i;
        }
    int m = 1;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            m *= (int)max[i] - 48;
    cout << m << endl;
}

Ответ

229635

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: