Программное решение задач ЕГЭ по информатике

Задача 5645. Источник: Поляков. Задание КИМ 24

Страница задачи 5645

(П. Финкель) Текстовый файл 24-230.txt состоит не более чем из 106 символов и содержит буквы английского алфавита и цифры. Определите максимальное число в этом файле, ограниченное двумя парами символов ZZ и удовлетворяющее маске «8???54???22», где символ ? обозначает любую цифру. Пример такого числа: 81235412322. Найдите произведение нечётных цифр найденного числа.

Решение

Если проанализировать содержимое файла, то можно обнаружить в нем комбинации из трех букв Z, в т.ч. и перед числом, удовлетворяющим шаблону. Поэтому решение с использованием метода split может дать неверный результат. Необходимо вручную идти от одной комбинации ZZ до другой и анализировать подстроку между ними. Это можно сделать встроенными средствами поиска подстроки в строке или через посимвольную обработку.

Python с использованием средств поиска подстроки

s = open('24-230.txt').readline()
mx = ''
start = s.find('ZZ')
while (start != -1):
    finish = s.find('ZZ', start + 1)
    if finish != -1:
        s1 = s[start + 2: finish]
        if len(s1) == 11 and s1.isdigit():
            if s1[0] == '8' and s1[4:6] == '54' and s1[9:] == '22':
                mx = max(mx, s1)
    start = finish
m = 1
for c in mx:
    if int(c) % 2 == 1:
        m *= int(c)
print(m)

Python с посимвольной обработкой

s = open('24-230.txt').readline()
mx = ''
last = -1
for i in range(len(s) - 1):
    if s[i] == 'Z' and s[i + 1] == 'Z':
        if last != - 1:
            s1 = s[last + 2:i]
            if len(s1) == 11 and s1.isdigit():
                if s1[0] == '8' and s1[4:6] == '54' and s1[9:] == '22':
                    mx = max(mx, s1)
        last = i
m = 1
for c in mx:
    if int(c) % 2 == 1:
        m *= int(c)
print(m)

PascalABC с использованием средств поиска подстроки

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
      if not c.IsDigit() then
      begin
            result := False;
            break;
      end;
end;

var
    start, finish, m: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-230.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    start := s.IndexOf('ZZ');
    while start <> -1 do
    begin
        finish := s.IndexOf('ZZ', start + 1);
        if finish <> -1 then
        begin
            s1 := s[start + 3:finish + 1];
            if (s1.Length = 11) and IsDigit(s1) then
                if (s1[1] = '8') and (s1[5:7] = '54') and (s1[10:] = '22') then
                    if s1 > max then
                        max := s1;
        end;
        start := finish;
    end;
    m := 1;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            m := m * (ord(c) - 48);
    Writeln(m);
end.

PascalABC с посимвольной обработкой

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
        if not c.IsDigit() then
        begin
            result := False;
            break;
        end;
end;

var
    last, i, m: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-230.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    last := -1;
    for i := 1 to s.Length - 1 do
        if (s[i] = 'Z') and (s[i + 1] = 'Z') then
        begin
            if last <> -1 then
            begin
                s1 := s[last + 2:i];
                if (s1.Length = 11) and IsDigit(s1) then
                    if (s1[1] = '8') and (s1[5:7] = '54') and (s1[10:] = '22') then
                        if s1 > max then
                            max := s1;
            end;
            last := i;
        end;
    m := 1;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            m := m * (ord(c) - 48);
    Writeln(m);
end.

C++ с использованием средств поиска подстроки

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-230.txt");
    string s, max = "";
    f >> s;
    int start = s.find("ZZ");
    while (start != -1)
    {
        int finish = s.find("ZZ", start + 1);
        if (finish != -1)
        {
            string s1 = s.substr(start + 2, finish - start - 2);
            if (s1.length() == 11 and isdigit(s1))
                if (s1[0] == '8' && s1.substr(4, 2) == "54" && s1.substr(9, 2) == "22")
                    if (s1 > max)
                        max = s1;
        }
        start = finish;
    }
    int m = 1;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            m *= (int)max[i] - 48;
    cout << m << endl;
}

C++ с посимвольной обработкой

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-230.txt");
    string s, max = "";
    f >> s;
    int last = -1;
    for (int i = 0; i < s.length() - 1; i++)
        if (s[i]== 'Z' && s[i + 1] == 'Z')
        {
            if (last != -1)
            {
                string s1 = s.substr(last + 2, i - last - 2);
                if (s1.length() == 11 and isdigit(s1))
                    if (s1[0] == '8' && s1.substr(4, 2) == "54" && s1.substr(9, 2) == "22")
                        if (s1 > max)
                            max = s1;
            }
            last = i;
        }
    int m = 1;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            m *= (int)max[i] - 48;
    cout << m << endl;
}

Ответ

76545

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: