Программное решение задач ЕГЭ по информатике

Задача 5644. Источник: Поляков. Задание КИМ 24

Страница задачи 5644

(П. Финкель) Текстовый файл 24-228.txt состоит не более чем из 106 символов и содержит буквы английского алфавита и цифры. Определите максимальное число в этом файле, ограниченное двумя парами символов XX и удовлетворяющее маске «3????78??45», где символ ? обозначает любую цифру. Пример такого числа: 31234781245. Найдите сумму нечётных цифр и произведение чётных цифр найденного числа, запишите в качестве ответа сумму этих двух чисел.

Решение

При анализе файла данных можно обнаружить, что он содержит последовательности из трех символов X, которые не будут корректно обрабатываться методом split. Хотя в данном файле нет числа удовлетворяющего шаблону, нет гарантии, что в другом файле такого числа не будет. Поэтому использование метода split недопустимо, т.к. может давать неверный ответ. Правильным будет последовательная обработка комбинаций XX и анализ подстрок между комбинациями на соответствие цифровому шаблону. Это можно сделать через посимвольный анализ строки или через использование стандартных средств поиска в строке.

Python через посимвольную обработку

s = open('24-228.txt').readline()
mx = ''
last = -1
for i in range(len(s) - 1):
    if s[i] == 'X' and s[i + 1] == 'X':
        if last != - 1:
            s1 = s[last + 2:i]
            if len(s1) == 11 and s1.isdigit():
                if s1[0] == '3' and s1[5:7] == '78' and s1[9:] == '45':
                    mx = max(mx, s1)
        last = i
m = 1
sm = 0
for c in mx:
    if int(c) % 2 == 1:
        sm += int(c)
    else:
        m *= int(c)
print(sm + m)

Python через использования средств поиска в строке

s = open('24-228.txt').readline()
mx = ''
start = s.find('XX')
while (start != -1):
    finish = s.find('XX', start + 1)
    if finish != -1:
        s1 = s[start + 2: finish]
        if len(s1) == 11 and s1.isdigit():
            if s1[0] == '3' and s1[5:7] == '78' and s1[9:] == '45':
                mx = max(mx, s1)
    start = finish
m = 1
sm = 0
for c in mx:
    if int(c) % 2 == 1:
        sm += int(c)
    else:
        m *= int(c)
print(sm + m)

PascalABC через посимвольную обработку

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
        if not c.IsDigit() then
        begin
            result := False;
            break;
        end;
end;

var
    last, i, m, sum: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-228.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    last := -1;
    for i := 1 to s.Length - 1 do
        if (s[i] = 'X') and (s[i + 1] = 'X') then
        begin
            if last <> -1 then
            begin
                s1 := s[last + 2:i];
                if (s1.Length = 11) and IsDigit(s1) then
                    if (s1[1] = '3') and (s1[6:8] = '78') and (s1[10:] = '45') then
                        if s1 > max then
                            max := s1;
            end;
            last := i;
        end;
    m := 1;
    sum := 0;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            sum := sum + ord(c) - 48
        else
            m := m * (ord(c) - 48);
    Writeln(sum + m);
end.

PascalABC через использования средств поиска в строке

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
      if not c.IsDigit() then
      begin
            result := False;
            break;
      end;
end;

var
    start, finish, m, sum: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-228.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    start := s.IndexOf('XX');
    while start <> -1 do
    begin
        finish := s.IndexOf('XX', start + 1);
        if finish <> -1 then
        begin
            s1 := s[start + 3:finish + 1];
            if (s1.Length = 11) and IsDigit(s1) then
                if (s1[1] = '3') and (s1[6:8] = '78') and (s1[10:] = '45') then
                    if s1 > max then
                        max := s1;
        end;
        start := finish;
    end;
    m := 1;
    sum := 0;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            sum := sum + ord(c) - 48
        else
            m := m * (ord(c) - 48);
    Writeln(sum + m);
end.

C++ через посимвольную обработку

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-228.txt");
    string s, max = "";
    f >> s;
    int last = -1;
    for (int i = 0; i < s.length() - 1; i++)
        if (s[i]== 'X' && s[i + 1] == 'X')
        {
            if (last != -1)
            {
                string s1 = s.substr(last + 2, i - last - 2);
                if (s1.length() == 11 and isdigit(s1))
                    if (s1[0] == '3' && s1.substr(5, 2) == "78" && s1.substr(9, 2) == "45")
                        if (s1 > max)
                            max = s1;
            }
            last = i;
        }
    int m = 1, sum = 0;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            sum += (int)max[i] - 48;
        else
            m *= (int)max[i] - 48;
    cout << sum + m << endl;
}

C++ через использования средств поиска в строке

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-228.txt");
    string s, max = "";
    f >> s;
    int start = s.find("XX");
    while (start != -1)
    {
        int finish = s.find("XX", start + 1);
        if (finish != -1)
        {
            string s1 = s.substr(start + 2, finish - start - 2);
            if (s1.length() == 11 and isdigit(s1))
                if (s1[0] == '3' && s1.substr(5, 2) == "78" && s1.substr(9, 2) == "45")
                    if (s1 > max)
                        max = s1;
        }
        start = finish;
    }
    int m = 1, sum = 0;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            sum += (int)max[i] - 48;
        else
            m *= (int)max[i] - 48;
    cout << sum + m << endl;
}

Ответ

6174

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: