Программное решение задач ЕГЭ по информатике

Задача 5642. Источник: Поляков. Задание КИМ 24

Страница задачи 5642

(П. Финкель) Текстовый файл 24-225.txt состоит не более чем из 106 символов и содержит буквы английского алфавита и цифры. Определите максимальное число в этом файле, ограниченное двумя парами символов RR и удовлетворяющее маске «322??55???89», где символ ? обозначает любую цифру. Пример такого числа: 322125512389. Найдите произведение нечётных цифр и сумму чётных цифр найденного числа, запишите в качестве ответа сумму этих двух чисел.

Решение

Если просмотреть файл с исходной строкой, то можно обнаружить там комбинации из трех букв R, в т.ч. и перед числом, удовлетворяющим шаблону. Следовательно, использовать метод split нельзя, т.к. он некорректно отделит данное число и, если оно является решением, результат будет неверным. Корректное решение заключается в последовательном поиске комбинаций RR и анализе подстроки между ними. Искать комбинации можно стандартными средствами поиска в строке или в процессе посимвольной обработки.

Python с использованием поиска в строке

s = open('24-225.txt').readline()
mx = ''
start = s.find('RR')
while (start != -1):
    finish = s.find('RR', start + 1)
    if finish != -1:
        s1 = s[start + 2: finish]
        if len(s1) == 12 and s1.isdigit():
            if s1[:3] == '322' and s1[5:7] == '55' and s1[10:] == '89':
                mx = max(mx, s1)
    start = finish
m = 1
sm = 0
for c in mx:
    if int(c) % 2 == 0:
        sm += int(c)
    else:
        m *= int(c)
print(sm + m)

Python посимвольная обработка

s = open('24-225.txt').readline()
mx = ''
last = -1
for i in range(len(s) - 1):
    if s[i] == 'R' and s[i + 1] == 'R':
        if last != - 1:
            s1 = s[last + 2:i]
            if len(s1) == 12 and s1.isdigit():
                if s1[:3] == '322' and s1[5:7] == '55' and s1[10:] == '89':
                    mx = max(mx, s1)
        last = i
m = 1
sm = 0
for c in mx:
    if int(c) % 2 == 0:
        sm += int(c)
    else:
        m *= int(c)
print(sm + m)

PascalABC с использованием поиска в строке

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
      if not c.IsDigit() then
      begin
            result := False;
            break;
      end;
end;

var
    start, finish, m, sum: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-225.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    start := s.IndexOf('RR');
    while start <> -1 do
    begin
        finish := s.IndexOf('RR', start + 1);
        if finish <> -1 then
        begin
            s1 := s[start + 3:finish + 1];
            if (s1.Length = 12) and IsDigit(s1) then
                if (s1[:4] = '322') and (s1[6:8] = '55') and (s1[11:] = '89') then
                    if s1 > max then
                        max := s1;
        end;
        start := finish;
    end;
    m := 1;
    sum := 0;
    foreach c in max do
        if ord(c) mod 2 = 0 then
            sum := sum + ord(c) - 48
        else
            m := m * (ord(c) - 48);
    Writeln(sum + m);
end.

PascalABC посимвольная обработка

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
        if not c.IsDigit() then
        begin
            result := False;
            break;
        end;
end;

var
    last, i, m, sum: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-225.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    last := -1;
    for i := 1 to s.Length - 1 do
        if (s[i] = 'R') and (s[i + 1] = 'R') then
        begin
            if last <> -1 then
            begin
                s1 := s[last + 2:i];
                if (s1.Length = 12) and IsDigit(s1) then
                    if (s1[:4] = '322') and (s1[6:8] = '55') and (s1[11:] = '89') then
                        if s1 > max then
                            max := s1;
            end;
            last := i;
        end;
    m := 1;
    sum := 0;
    foreach c in max do
        if ord(c) mod 2 = 0 then
            sum := sum + ord(c) - 48
        else
            m := m * (ord(c) - 48);
    Writeln(sum + m);
end.

C++ с использованием поиска в строке

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-225.txt");
    string s, max = "";
    f >> s;
    int start = s.find("RR");
    while (start != -1)
    {
        int finish = s.find("RR", start + 1);
        if (finish != -1)
        {
            string s1 = s.substr(start + 2, finish - start - 2);
            if (s1.length() == 12 and isdigit(s1))
                if (s1.substr(0, 3) == "322" && s1.substr(5, 2) == "55" && s1.substr(10, 2) == "89")
                    if (s1 > max)
                        max = s1;
        }
        start = finish;
    }
    int m = 1, sum = 0;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 0)
            sum += (int)max[i] - 48;
        else
            m *= (int)max[i] - 48;
    cout << sum + m << endl;
}

C++ посимвольная обработка

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-225.txt");
    string s, max = "";
    f >> s;
    int last = -1;
    for (int i = 0; i < s.length() - 1; i++)
        if (s[i]== 'R' && s[i + 1] == 'R')
        {
            if (last != -1)
            {
                string s1 = s.substr(last + 2, i - last - 2);
                if (s1.length() == 12 and isdigit(s1))
                    if (s1.substr(0, 3) == "322" && s1.substr(5, 2) == "55" && s1.substr(10, 2) == "89")
                        if (s1 > max)
                            max = s1;
            }
            last = i;
        }
    int m = 1, sum = 0;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 0)
            sum += (int)max[i] - 48;
        else
            m *= (int)max[i] - 48;
    cout << sum + m << endl;
}

Ответ

14211

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: