Программное решение задач ЕГЭ по информатике

Задача 5641. Источник: Поляков. Задание КИМ 24

Страница задачи 5641

(П. Финкель) Текстовый файл 24-225.txt состоит не более чем из 106 символов и содержит буквы английского алфавита и цифры. Определите максимальное число в этом файле, ограниченное двумя парами символов CC и удовлетворяющее маске «234???57???8», где символ ? обозначает любую цифру. Пример такого числа: 234123574568. Найдите произведение нечётных цифр найденного числа.

Решение

Анализ файла данных показывает наличие в нем последовательностей из трех символов C. Хотя после такой комбинации нет чисел, нет гарантии, что их не может быть в другом файле данных. Поэтому использование метода split может дать неверный результат. Для получения гарантированного верного результата необходимо искать последовательности CC и анализировать подстроки между ними.

Python с использованием посимвольной обработки

s = open('24-225.txt').readline()
mx = ''
last = -1
for i in range(len(s) - 1):
    if s[i] == 'C' and s[i + 1] == 'C':
        if last != - 1:
            s1 = s[last + 2:i]
            if len(s1) == 12 and s1.isdigit():
                if s1[:3] == '234' and s1[6:8] == '57' and s1[11] == '8':
                    mx = max(mx, s1)
        last = i
m = 1
for c in mx:
    if int(c) % 2 == 1:
        m *= int(c)
print(m)

Python с использованием поиска в строке

s = open('24-225.txt').readline()
mx = ''
start = s.find('CC')
while (start != -1):
    finish = s.find('CC', start + 1)
    if finish != -1:
        s1 = s[start + 2: finish]
        if len(s1) == 12 and s1.isdigit():
            if s1[:3] == '234' and s1[6:8] == '57' and s1[11] == '8':
                mx = max(mx, s1)
    start = finish
m = 1
for c in mx:
    if int(c) % 2 == 1:
        m *= int(c)
print(m)

PascalABC с использованием посимвольной обработки

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
        if not c.IsDigit() then
        begin
            result := False;
            break;
        end;
end;

var
    last, i, m: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-225.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    last := -1;
    for i := 1 to s.Length - 1 do
        if (s[i] = 'C') and (s[i + 1] = 'C') then
        begin
            if last <> -1 then
            begin
                s1 := s[last + 2:i];
                if (s1.Length = 12) and IsDigit(s1) then
                    if (s1[:4] = '234') and (s1[7:9] = '57') and (s1[12] = '8') then
                        if s1 > max then
                            max := s1;
            end;
            last := i;
        end;
    m := 1;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            m := m * (ord(c) - 48);
    Writeln(m);
end.

PascalABC с использованием поиска в строке

function IsDigit(s: String): Boolean;
var
    c: Char;
begin
    result := True;
    foreach c in s do
      if not c.IsDigit() then
      begin
            result := False;
            break;
      end;
end;

var
    start, finish, m: Integer;
    max, s, s1: String;
    c: Char;
    f: TEXT;
begin
    Assign(f, '24-225.txt');
    Reset(f);
    Readln(f, s);
    max := '';
    start := s.IndexOf('CC');
    while start <> -1 do
    begin
        finish := s.IndexOf('CC', start + 1);
        if finish <> -1 then
        begin
            s1 := s[start + 3:finish + 1];
            if (s1.Length = 12) and IsDigit(s1) then
                if (s1[:4] = '234') and (s1[7:9] = '57') and (s1[12] = '8') then
                    if s1 > max then
                        max := s1;
        end;
        start := finish;
    end;
    m := 1;
    foreach c in max do
        if ord(c) mod 2 = 1 then
            m := m * (ord(c) - 48);
    Writeln(m);
end.

C++ с использованием посимвольной обработки

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-225.txt");
    string s, max = "";
    f >> s;
    int last = -1;
    for (int i = 0; i < s.length() - 1; i++)
        if (s[i]== 'C' && s[i + 1] == 'C')
        {
            if (last != -1)
            {
                string s1 = s.substr(last + 2, i - last - 2);
                if (s1.length() == 12 and isdigit(s1))
                    if (s1.substr(0, 3) == "234" && s1.substr(6, 2) == "57" && s1[11] == '8')
                        if (s1 > max)
                            max = s1;
            }
            last = i;
        }
    int m = 1;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            m *= (int)max[i] - 48;
    cout << m << endl;
}

C++ с использованием поиска в строке

#include <iostream>
#include <fstream>
using namespace std;

bool isdigit(string s)
{
    for (int i = 0; i < s.length(); i++)
        if (s[i] < '0' or s[i] > '9')
            return false;
    return true;
}

int main()
{
    ifstream f;
    f.open("24-225.txt");
    string s, max = "";
    f >> s;
    int start = s.find("CC");
    while (start != -1)
    {
        int finish = s.find("CC", start + 1);
        if (finish != -1)
        {
            string s1 = s.substr(start + 2, finish - start - 2);
            if (s1.length() == 12 and isdigit(s1))
                if (s1.substr(0, 3) == "234" && s1.substr(6, 2) == "57" && s1[11] == '8')
                    if (s1 > max)
                        max = s1;
        }
        start = finish;
    }
    int m = 1;
    for (int i = 0; i < max.length(); i++)
        if ((int)max[i] % 2 == 1)
            m *= (int)max[i] - 48;
    cout << m << endl;
}

Ответ

972405

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: