Программное решение задач ЕГЭ по информатике

Задача 5919. Источник: Поляков. Задание КИМ 14

Страница задачи 5919

(Е. Джобс) Известно, что значение выражения 36x538 – 4y38 является положительным и минимальным. Известно, что x и y – допустимые комбинации из одной или нескольких цифр восьмеричной системы счисления. Определите значение выражения. В качестве ответа запишите полученное число в десятичной системе счисления. Основание системы счисления указывать не нужно.

Решение

Задача легко решается с минимальным кодом и даже вручную. Очевидно, что минимальный результат разности будет, если уменьшаемое будет, как можно меньше, а вычитаемое - как можно больше. Поэтому, x = 0, а y = 778 (при большем количестве разрядов результат будет отрицательным). Вычисляем выражение.

Python

print(int("36053", 8) - int("4773", 8))

PascalABC

var
    n1, n2: Integer;
begin
    n1 := 3 * 8 * 8 * 8 * 8 + 6 * 8 * 8 * 8 + 5 * 8 + 3;
    n2 := 4 * 8 * 8 * 8 + 7 * 8 * 8 + 7 * 8 + 3;
    Writeln(n1 - n2);
end.

C++

#include <iostream>
using namespace std;
int main()
{
    int n1 = 3 * 8 * 8 * 8 * 8 + 6 * 8 * 8 * 8 + 5 * 8 + 3;
    int n2 = 4 * 8 * 8 * 8 + 7 * 8 * 8 + 7 * 8 + 3;
    cout << n1 - n2 << endl;
}

Ответ

12848

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: