Программное решение задач ЕГЭ по информатике

Задача 5883. Источник: Поляков

Страница задачи 5883

(П. Волгин) Операнды арифметического выражения записаны в системах счисления с основанием 17:

10x017 + F0xFF17

В записи чисел переменной x обозначена неизвестная цифра из алфавита 17-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 13. Для найденного значения x вычислите частное от деления значения арифметического выражения на 13 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

for x in range(17):
    n1 = 17 ** 3 + x * 17
    n2 = 15 * 17 ** 4 + x * 17 ** 2 + 15 * 17 + 15
    n = n1 + n2
    if n % 13 == 0:
        print(n // 13)
        break

PascalABC

var
    x, n, n1, n2: Integer;
begin
    for x := 0 to 16 do
    begin
        n1 := trunc(power(17, 3)) + x * 17;
        n2 := 15 * trunc(power(17, 4)) + x * trunc(power(17, 2)) + 15 * 17 + 15;
        n := n1 + n2;
        if n mod 13 = 0 then
        begin
            Writeln(n div 13);
            break;
        end;
    end;
end.

C++

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    for (int x = 0; x < 17; x++)
    {
        int n1 = (int)pow(17, 3) + x * 17;
        int n2 = 15 * (int)pow(17, 4) + x * (int)pow(17, 2) + 15 * 17 + 15;
        int n = n1 + n2;
        if (n % 13 == 0)
        {
            cout << n / 13 << endl;
            break;
        }
    }
}

Ответ

97028

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: