Программное решение задач ЕГЭ по информатике

Задача 5813. Источник: Поляков

Страница задачи 5813

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

1121x234 + 1111x243

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 15. Для найденного значения x вычислите частное от деления значения арифметического выражения на 15 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    r1 = 10234 + x * 1000
    r2 = 10243 + x * 1000
    n1 = r1 ** 2 + r1 + 2
    n2 = r2 ** 2 + r2 + 1
    n = n1 + n2
    if n % 15 == 0:
        result = n // 15
print(result)

PascalABC

var
    x, n, r1, r2, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        r1 := 10234 + x * 1000;
        r2 := 10243 + x * 1000;
        n1 := r1 * r1 + r1 + 2;
        n2 := r2 * r2 + r2 + 1;
        n := n1 + n2;
        if n mod 15 = 0 then
            r := n div 15;
    end;
    Writeln(r);
end.

C++

#include <iostream>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int r1 = 10234 + x * 1000;
        int r2 = 10243 + x * 1000;
        int n1 = r1 * r1 + r1 + 2;
        int n2 = r2 * r2 + r2 + 1;
        int n = n1 + n2;
        if (n % 15 == 0)
            r = n / 15;
    }
    cout << r << endl;
}

Ответ

44354819

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: