Программное решение задач ЕГЭ по информатике

Задача 5808. Источник: Поляков

Страница задачи 5808

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

131x234 + 13x1234

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 13. Для найденного значения x вычислите частное от деления значения арифметического выражения на 13 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    r1 = 10234 + x * 1000
    r2 = 1234 + x * 10000
    n1 = r1 + 3
    n2 = r2 + 3
    n = n1 + n2
    if n % 13 == 0:
        result = n // 13
print(result)

PascalABC

var
    x, n, r1, r2, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        r1 := 10234 + x * 1000;
        r2 := 1234 + x * 10000;
        n1 := r1 + 3;
        n2 := r2 + 3;
        n := n1 + n2;
        if n mod 13 = 0 then
            r := n div 13;
    end;
    Writeln(r);
end.

C++

#include <iostream>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int r1 = 10234 + x * 1000;
        int r2 = 1234 + x * 10000;
        int n1 = r1 + 3;
        int n2 = r2 + 3;
        int n = n1 + n2;
        if (n % 13 == 0)
            r = n / 13;
    }
    cout << r << endl;
}

Ответ

8498

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: