Программное решение задач ЕГЭ по информатике

Задача 5806. Источник: Поляков

Страница задачи 5806

(А. Богданов) Операнды арифметического выражения записаны в системе счисления с некоторым частично заданным основанием:

15123x5 + 151x233

В записи чисел переменной x обозначена неизвестная цифра. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 14. Для найденного значения x вычислите частное от деления значения арифметического выражения на 14 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение

Python

result = 0
for x in range(10):
    r1 = 12305 + x * 10
    r2 = 10233 + x * 1000
    n1 = r1 + 5
    n2 = r2 + 5
    n = n1 + n2
    if n % 14 == 0:
        result = n // 14
print(result)

PascalABC

var
    x, n, r1, r2, n1, n2, r: Integer;
begin
    for x := 0 to 9 do
    begin
        r1 := 12305 + x * 10;
        r2 := 10233 + x * 1000;
        n1 := r1 + 5;
        n2 := r2 + 5;
        n := n1 + n2;
        if n mod 14 = 0 then
            r := n div 14;
    end;
    Writeln(r);
end.

C++

#include <iostream>
using namespace std;
int main()
{
    int r = 0;
    for (int x = 0; x < 10; x++)
    {
        int r1 = 12305 + x * 10;
        int r2 = 10233 + x * 1000;
        int n1 = r1 + 5;
        int n2 = r2 + 5;
        int n = n1 + n2;
        if (n % 14 == 0)
            r = n / 14;
    }
    cout << r << endl;
}

Ответ

1827

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: