Программное решение задач ЕГЭ по информатике

Задача 5722. Источник: Поляков

Страница задачи 5722

(А. Игнатюк) Исполнитель «Аппо» получает на вход четырехзначное число N и строит новое число R по следующим правилам:

  1. Если первая цифра числа N делится на 4, то в числе R заменяем её на цифру 9.
  2. Если первая цифра числа N делится на 2 и не делится на 4, то в числе R заменяем её на цифру 3.

Сколько существует чисел N, для которых соответствующее число R начинается с цифры 9, а восьмеричная запись числа R оканчивается цифрой 4?

Решение

В данной задаче второй пункт алгоритма абсолютно не влияет на решение, что дает возможность его игнорировать. Числа, начинающиеся с цифры 9 могут быть получены только из чисел начинающихся с цифр 4 и 8, которые будут заменены, а так же цифры 9, которая меняться не будет. Таким образом, каждый результат алгоритма может быть получен из трех различных чисел. В цикле анализируем каждый результат алгоритма. Если остаток от деления на 8 равен 4, то к счетчику прибавляем 3.

Данная задача может быть решена и без программирования, если понять, что из тысячи интересующих нас результатов работы алгоритма ровно 1/8 часть будет иметь в конце восьмеричного числа цифру 4.

Python

k = 0
for r in range(9000, 10000):
    if r % 8 == 4:
        k += 3
print(k)

PascalABC

var
    r, k: Integer;
begin
    k := 0;
    for r := 9000 to 9999 do
        if r mod 8 = 4 then
            k := k + 3;
    Writeln(k);
end.

C++

#include <iostream>
using namespace std;
int main()
{
    int k = 0;
    for (int r = 9000; r < 10000; r++)
        if (r % 8 == 4)
            k += 3;
    cout << k << endl;
}

Ответ

375

Отправить замечание по решению

Код по которому имеется замечание:

Ваш вариант кода:

Комментарий: